Thinkpad yoga 260: no signs of power

avatar
Dec. 7, 2021, 3:05 a.m.

I recently got this ThinkPad Yoga 260 for free from a school and there are no signs of power. When I plug the charger in, nothing happens, no fans spin and no lights come on.

I’ve tried taking the board out and cleaning it with 99.9% IPA but still nothing.

Anyone knows what it could be? Or should I just buy a new board for $100.

Replies
7
Views
205
avatar
Nov. 23, 2021, 7:35 p.m.

Did you check the Power adapter if it has power output?

yep the power adapter works on another Thinkpad.

avatar
Dec. 7, 2021, 6:01 p.m.

At least you need a multimeter to check further. Inspect capacitor with magnifiers.

avatar
Nov. 23, 2021, 7:35 p.m.

Memory or graphic card

would memory stop it from getting any power at all?

No. You'd get the RAM error beep, which would be good because then it shows that there's life in the planar.

that’s what happens when I press the power button.

it would beep or give any sign of life. that's clearly a power issue.

avatar
Nov. 23, 2021, 7:35 p.m.

Component or Motherboard failure.

yeah motherboard failure

avatar
Dec. 7, 2021, 4:20 a.m.

Was my second Yoga and I really liked it !
Just got my X380 on Monday
Hope you can get it fixed and worst case a new / used mobo and you're fine !

yep that’s what I’ll just do, nice little machine.

avatar
Dec. 7, 2021, 1:34 p.m.

double check the power circuit, if there's any brownish components behind the psu, that's it. other things to check, the voltage out of your power supply, and if it reaches the motherboard. leave it plugged longer eventually, sometimes a well drained battery will need to have a bit of backup so the motherboards gets enough amperage to have a go for the power.
if anything, the power led would lit.

yeah it’s definitely something to do with the power delivery as there’s no power light and when I checked it with my multimeter there was a spark. I’ll just order a new motherboard.

avatar
Dec. 7, 2021, 9:38 p.m.

If you plug the adapter in, the red led in the ThinkPad logo should blink three times. If it doesn't, then the planar is suspect. Try unplugging the CMOS battery for 10 minutes and then connect the adapter without connecting the CMOS battery first and see if the led blinks.

Also, I see your RAM slot is empty. Did you just remove the brick or what? The Yoga 260 doesn't have soldered RAM.

yep I removed the ram from it to test in another machine. The Thinkpad light doesn’t blink so I’ll try unplugging cmos battery.

Unplug the main battery too for good measure.

yep just unplugged both so will see what happens 🤞🏼

These guys are really sturdy. I revived one that got left out on a car roof during a rainy winter night here in Iceland, and it was still there when the owner got in the car and drove to work the next morning only to see it come flying off the roof and smack into the asphalt when she hit the brakes.

I was absolutely amazed that I managed to revive it.

wow lucky that it survived. I feel like the newer ones aren’t as reliable though as this is the 6th faulty modern Thinkpad I’ve received.

still no sign of power after leaving battery and cmos unplugged for 10 minutes so it’s probably a dead motherboard.

really depends on the model. I had an IBM built R51 (mainstream/budget model) that had a motherboard fail. I’ve owned at least 5 Lenovo-built X, W, T and P series (all premium tier) devices and not a single issue with any of them. Contrary to popular belief, IBM was not an infallible god and Lenovo did not run the quality into the ground across the board. It’s not that simple. IBM was great but the plastics are still more brittle on a lot of those old machines vs. the newer Lenovo ones. I’d say Lenovo has done as good a job as anyone, including IBM, could have considering that no one can get away with charging $3-5,000 for a laptop with mid-level specs like they did in IBM’s heyday.




Suggested Topics
Topic
Category
User
Replies
Views
Activity