please help! my Thinkpad t60 doesn't turn on after disassembled

avatar
Oct. 5, 2021, 1:14 a.m.

Hello Everyone, please help...I disassembled my Thinkpad t60, when putting it back together... doesn't turn on ...just the charging lights...any ideas, suggestions?
Many thanksHello Everyone, please help...I disassembled my Thinkpad t60, when putting it back together... doesn't turn on ...just the charging lights...any ideas, suggestions?
Many thanks

Replies
8
Views
205
avatar
Oct. 5, 2021, 12:48 a.m.

Suggest you uncover the insides and double check all and any connectors etc.

yeah...I changed the motherboard with a r60.one...but forgot not to disconnect the bios battery and now it doesn't light up...I am using a flashlight. I think There is a bios or windows XP problem

avatar
Oct. 5, 2021, 5:37 a.m.

Yes ... I have plugged it in, unplugged ,try with battery, without, trued pressing start button for 30 seconds...arming and des-arming everything back again...not sure what to do anymore...

avatar
Oct. 5, 2021, 12:48 a.m.

Have you plug it in?

yes plugging,unplugging, with battery and without, pressing the start button for 30 seconds, arming and dis- arming

avatar
Oct. 5, 2021, 12:48 a.m.

Check all cables

Yes, thanks...

avatar
Oct. 5, 2021, 12:48 a.m.

Memory in place properly?

Yes ...all checked

avatar
Oct. 5, 2021, 12:48 a.m.

Did you change any components?

I now changed the motherboard with a Thinkpad r60 I had laying around with no panel...but now the screen doesn't light up...I am.using a flashlight to see the booting menu and bios...I think there is a problem with the windows XP...

avatar
Oct. 5, 2021, 12:48 a.m.

Before disable it, did you disable internal battery from bios menu?

you mean CMOS battery? Because T60 only have 1 battery not double battery

No. Based on my experience. Before dissemble it, you should go to bios and disable internal battery. This is to make sure that the battery not delivering any power or electricity during the dissembling process. If you bay pass this, means that the battery still power up the components while you ripped them out, and that may cause electricity short and damage circuit(s).

But first, try to double check all screws and connectors inside. Make sure all of them assembled correctly. Hope that is not electricity short or circuits damage.
 

T60 doesn't have internal battery as I know, because I have T61 that a later series than T60 and it doesn't have internal battery. T60 and T61 use the same battery pack.
Internal battery if not mistaken started from gen 4 such as X240 and so on

Yep no internal battery on the T60

avatar
Oct. 5, 2021, 9:49 p.m.

I would go back and double check all the connections. Also take out the ram and put it back in. If you have a different ram stick try that too.

Thanks ...




Suggested Topics
Topic
Category
User
Replies
Views
Activity